Unexpected errors and messages displayed by Microsoft when trying to access your Microsoft 365 account via RM Unify.
Published Date : 11 Feb 2019
Last Updated : 23 Jul 2024
Content Ref: TEC6654673
Operating System
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Part No
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Summary
Explains why users see a looping 'Pick an account' popup, or sign in box, possibly with an "Oops, something went wrong. An unexpected error has occurred while signing you in" error when clicking an Microsoft 365 tile from the RM Unify Launch Pad.
Symptoms
Your RM Unify establishment is federated to a domain in Microsoft® 365™. When a user clicks a Microsoft 365 app tile from their RM Unify Launch Pad, instead of being directed straight to the app, they see one or more of the following symptoms:
Microsoft 'Pick an account' sign in page (see the screenshot below).
A looping Microsoft sign in window 'Taking you to your organization's sign-in page'.
An error page "Oops, something went wrong. An unexpected error has occurred while signing you in".
Cause
This can occur in the following circumstances:
The Microsoft 365 account, mailbox, etc. have not yet been provisioned by Microsoft.
The Microsoft 365 account has been blocked.
The Microsoft 365 account username (also known as the user principal name) has been changed and no longer matches the email address of the user in RM Unify.
The Microsoft 365 account does not have a unique link to the user's RM Unify account.
Requirements
If the Microsoft 365 account, mailbox, etc. have not yet been provisioned (an admin can check this within the 'Microsoft 365 admin center' itself), then wait until they have and retry access from RM Unify again.
Procedure
To unblock a Microsoft 365 account
Sign in to Microsoft 365 as a global administrator.
In Users, Active Users, search for and select the user.
Click 'Unblock sign-in'.
Click Save, Close.
To check the Microsoft 365 account username
Sign in to Microsoft 365 as a global administrator.
In Users, Active Users, search and select the user.
Next to Username/Email, click Edit.
Confirm the email address showing 'Primary email address and username' matches the email address held for the user in the RM Unify Management Console.
If it does not match and the RM Unify email address is instead showing under Aliases, then, next to the RM Unify email address, click 'Set as primary', 'Save to re-assign the RM Unify email address as the primary address'.
To check the link between the Microsoft 365 and RM Unify account
Please contact the RM Unify Support team or your usual network provider for assistance.
If this article has not helped provide a solution then it is also possible to
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Document Keywords: o365, Microsoft 365, looping, signing in, users are asked to sign in when clicking an Office 365 tile from the Unify Launchpad, onedrive, mail, loop, unable to logon, sign-in, oops something went wrong, pick an account, not provisioned, TEC6654673